Wallet / Ledger Question

Got a NUC10 to test out the network, and have my full node running.

Then I got to the “Join as a Validator” section and saw the need for tokens.

This then got me reading up on how to procure SCRT / wallet / etc. Some questions:

Reading through: https://secretnodes.org/#/tutorials/ledger-swap

I have my ledger in dev mode and only have version 2.16.1 of the Cosmos(Atom) app available to me. Is this ok?

As for the actual interface - what are people using? Ledger live doesn’t have the ability to work with SCRT. So I then pop’ed over to https://puzzle.report/ signup/etc and log’ed in at present. It also seemed to be the ‘next step’ in the above process.

However, once in - I don’t see any way to generate an address using my Ledger.

Now my NUC10 is running as a full node, and I have been able to generate an account (in fact it is:
secret1pc4za4w3z0pfgqxl3ary9zlhmfa528uutv65ud). However, I was hoping to use the ledger.

I even went back to https://secretnodes.org/#/tutorials/ledger-swap and looked at the binaries listed; however, these give me “enigmacli” and I don’t see the necessary subcommands to access the ledger. In fact, I don’t think that this has anything at all to do with wallet functionality (could be off though).

Thanks in advance.

UPDATE: I visited https://explorer.cashmaney.com/ and was able to get my ledger to work.

1 Like

@jflowers is this resolved then? Or still need assistance? :slight_smile:

I guess it is resolved; however, perhaps though an update to the docs is in order?

I think folks will need to know what websites offer support/an interface to use one’s ledger device. Beyond explorer.cashmaney.com, what other sites offer support? ( I could see how some might think there’s presently native support inside of Live for example. ) Thanks.

I also have the same problem. I’ve got a Ledger Nano X and and only have version 2.16.1 of the Cosmos(Atom) app available to me.

I am never able to get the Ledger recognized for any validator, doing everything properly and am in the Cosmos app.

I’ve tried going to https://explorer.cashmaney.com/ but it’s still not being recognized.

Just confirmed that I’m rocking the same ver of the app: 2.16.1 on my ledger x.

I have the app running on my ledger before going to explorer.cashmaney.com; once there - I click on the “key” icon - and I’m log’ed in using my ledger.

I should also note that I’m running this on a Mac (10.14.x) and using the latest chrome.

1 Like

I perform the same and it says:
Please make sure your Ledger device is connected and Cosmos App 1.5.0 or above is opened.
No device selected."

explorer.cashmaney.com wants to connect… error: no compatable devices found”

Anyone else having the same issue using 2.16.1 with a nano X?