Unable to swap sSCRT-SXMR on holodeck

I attempt to enter in amounts and when I hit enter the amount goes back to zero.
I tried reversing the ordering of tokens with the same result. I can provide liquidity for this pair. Just can’t swap.

I recall having a similar situation when I was beta testing secretswp back in February.

I would like to get the sSCRT-sXMR pair working in secretswap on holodeck before I write a blog post on the Secret Monero Bridge v0.0.1 release.

What’s the token’s address? I think It needs to be added to the router.

The sXMR token address is secret15m0feupa7nrk3gl8kzep38vecxr7lzuhv6dyfg

I added it to the testnet router, should be usable now :slight_smile:


That did it! Thanks guys.


@maxkoda please send a PR similar to this to the staging branch if you redeploy the token.

really cool to see the progress on this. I was doing some googling the other day and searched Monero bridge. I found some links to this work, but nothing else. Admittedly I didn’t look too hard, but this appears to be the only game in town.

Ok. We will be looking to use the recently enhanced SNIP-21 for sXMR prior to launching on the mainnet.

Thank you.