error[E0463]: can't find crate for `std`


I am trying to launch Enigma Docker Network by running ./launch_network.bash , but I came up with the following error.

I tried to reinstall rust by following

but still shows the same error.

Could someone help me for this problem?

core_1 | Compiling sgx_tunittest v1.0.0 (
core_1 | error[E0463]: can’t find crate for std

1 Like

Inside enigma-core docker try the troubleshooting section and then manually re-compile core:

Currently the Docker network needs more stabilization.

1 Like

Thanks for your help!

I tried the troubleshooting, but my case was much worse than expected, so I restarted from updating bios and clean-installing OS.

I succeeded in running enigma docker network using:
intel core i5 8400
gigabyte h370n bios version F6
ubuntu 16.04.4
kernel 4.13.0-45-generic

That’s great news. What laptop are you using?
@ainsley that’s helpful information for our list of supported machines :slight_smile:

1 Like

It is not a laptop but I bought the motherboard and the CPU separately.

I summarized the detailed process to run the enigma socket network in the following site, but written in Japanese.


Hi guys, I also tried the rm -rf workaround but still get the error at core_1 phase. Any ideas whats going wrong?

  1. Type:
    rm -rf /root/.cargo/git/checkouts/rust-sgx-sdk-fc8771c5c45bde9a/378a4f0/xargo/
  2. recompile - make

In reference to the building steps for Core, yes, this is a workaround, but not when you encounter this error setting up the enigma-docker-network using standard mode. Ref:

@Fergal This issue has been fixed in the latest commit to enigma-docker-network:

Pull the latest version of the master branch and try again.

1 Like

@victor the party has started. Thanks a million for your help!