Restaking Error using Math Wallet DApp

I’ve been having difficulty using the “Restake” function in the Math Wallet DApp. Out of about 20 attempts, I have been successful only once and now continue to encounter an error with each attempt. While I understand that there is a 21 day unstaking period, I thought that tokens could be restaked at any time (within reasonable limits). I read somewhere that there is a rule related to 7 validators and don’t fully understand it; however, this shouldn’t apply as the tokens that I was attempting to restake were staked with the original (i.e. first) validator.

During my initial attempt, I first withdrew my rewards from the validator and then tried to delegate a portion of my stake to another validator using the “Restake” function. After signing the Math Wallet request, I received the following message: “m.maiziqianbao.net says…error not defined.” I tried several times and with different validators but always ended up with the same result. Thinking that perhaps my reward withdrawal might be the reason for the error, I gave up and decided to try again after another 21 days.

So I tried again today without withdrawing my rewards, and I was able to restake to another validator. However, I encountered the same error on my subsequent attempts to perform the same action.

Furthermore, I can’t get the “Reinvest” function to work, either. This error message simply says “failed.” The workaround is easy - withdraw, then stake the amount withdrawn - so this isn’t a big issue but thought I would mention it.

Has anyone else either encountered these issues or know the reason for the failures? A more detailed explanation about the restaking rules and limits would also be great if someone could be so kind! If it turns out that I should be allowed to perform these actions, then at least I know the issue is likely with the wallet extension…but if that’s the case, then why did it work that one time?

For reference, I’m running Win 10 x64 and using Brave Browser with Math Wallet extension.

Cheers,
Matt

Just to touch base, Matwallet has some issues with some of the functionality (with the D-App).
Issues you raised would be better to get in touch with Mathwallet support. ( Also i dont think they support the re-invest option yet, as some of the TG members shared)

Currently, the wallet I would recommend is Keplr as they are supporting the Secret Network(Actively).
You can migrate your wallet ( private key/seed) from one wallet to the other very easily.

2 Likes

Thanks for the quick reply! Migrating to Keplr sounds like the easiest resolution.

Do you think there is risk of losing money with mathwallet Dapp bugs?

As long as you hold your private key, i don’t see, there to be an issue in terms of security.
But the D-app if you play it wrong at worst would put you in a 21-day unbonding (Where you would not make any rewards)

How do you migrate a wallet?

Just export the private key or Memonic and import it in the other wallet.

1 Like

thanks :slight_smile: I thought that might be it