Enigma node startup on NUC 7i5 BNB giving error. Need Help!

I installed a node on a Intel NUC 7i5BNB. The install was done following the guide to the T.
SGX enabled in BIOS and safe mode disabled.
Installation was a success
Encountered some problems with starting the node:
start.sh: line 6: cd: discovery-docker-network: No such file or directory
Making sure discovery-docker-network is up to date.
Can’t find a suitable configuration file in this directory or any
parent. Are you in the right directory?

    Supported filenames: docker-compose.yml, docker-compose.yaml

Start 9 workers on your Secret Node. Note : 9 is the max amount of workers you can run.
sudo: ./launch.bash: command not found

Found the discovery-docker-network directory was not created as per the above error message so created one and copied the tmp folder contents to the discovery-docker-network folder in /home/nsn/ Is this step correct ?

After that i started the node , it pulled the docker images and then got the below error message and am not able to make anything about the env-template

CD into Discovery-Docker-Network
Making sure discovery-docker-network is up to date.
WARNING: The DOCKER_TAG variable is not set. Defaulting to a blank string.
WARNING: The SGX_MODE variable is not set. Defaulting to a blank string.
WARNING: The COMPOSE_PROJECT_NAME variable is not set. Defaulting to a blank string.
Pulling contract … done
Pulling p2p … done
Pulling client … done
Pulling core … done
Pulling km … done
Start 9 workers on your Secret Node. Note : 9 is the max amount of workers you can run.
[sudo] password for nsn:
Creating .env file from template
cp: cannot stat ‘.env-template’: No such file or directory
./launch.bash: line 11: .env: No such file or directory
SGX_MODE not set to either HW or SW in .env file. Exiting…

Please help!! Not a programmer, but have experience running a few nodes on ubuntu.

Did you try any of the troubleshooting tips the guide links to? Try that, If it still doesn’t work then let me know. Also the guide is about to be updated after the upcoming testing. Not sure what changes / additions will need to be made to it yet.

1 Like

I followed the troubleshooting guide but nothing regarding he env-template

Try the SGX Troubleshootingsection. If that doesn’t work you may need to wait for the guide to be updated.

Secure boot is disabled, but there is no safe boot option in Bios. Fast boot is also disabled

For context the current tutorial / scripts simply install all the stuff required for the system to be able to run an enigma node, such as SGX, the discovery docker container, etc. These are the things people typically have to manually install are all located in this repo.


So If you don’t have the docker container installed then the installation didn’t actually complete successfully. If you share the output of where your install failed exactly then someone could probably spot the issue pretty quickly.

The install has not failed. The install has completed successfully. When i give the bash start.sh command is when i get the errors. The discover docker images downloaded and after that it starts launch.sh which give the error as i have said above.

The issue you are having tells us the installer didn’t work on your system for some reason (yet it does not reveal the why).

I’d recommend starting from scratch on the guide with a fresh install, I understand it may sound tedious but you should get as familiar as you can with the process so you can empower yourself.

While going through the install be sure to read the output from the script, making sure it all goes smoothly, and sharing the final output of the script if you have the issue running through the guide again. As previously stated I am stretched a bit thin at the moment, but I will be taking what we learn from the testing to improve the current guides and improved ones will be available in time for the Games. Until then, if you can get us the output that’s all we need to try and come up with next steps for you.

If you haven’t made any ground on this… Can you please try this.

sudo rm -f discovery-docker-network
sudo apt-get install git
sudo git clone https://github.com/enigmampc/discovery-docker-network.git

then run
sudo bash start.sh

please let me know if it runs or if you get the same error.
If so, then as @moonstash says, you will need to start fresh.

I installed the discovery testnet and now its working as i see the workers starting. Didnt go with CLI.sh as its not clear from which account i have to send the KETH. Should i send the KETH fromt he same account from which i will be staking test ENG? Which account will i receive the test ENG - It will be the same account in which i hold the mainnet ENG tokens ?

You cannot proceed past that spot unless you already have test eng as the notice says. Do not expect support on this step until the notice goes away.