Messed up viewing key on Sefi claim

Hey guys, Hope you can help but think I shafted myself somehow.

I went to the sefi tab to claim and paid for the viewing key. Went through and it was highlighted in green. Then I went back to my keplr wallet and went into the secret scrt tab. A pop up to make another key came up. So i approved it and it went through. However, when I went back to the sefi tab, it now says wrong viewing key in red. If I try to claim I just get an failed tx now. I’ve been looking through faq’s but I can’t find anything. Is there anyway to fix this or did I just screw myself?

1 Like

I am having the same exact problem. I tried to create the key. And then it asked me to do it again. Now when it did it says Wrong Viewing Key in red, and there is nothing I can do.

1 Like

I am having the same error, How do i delete this viewing key to start again?

1 Like

Likewise. I am super stumped. The viewing key was fine for me for hours and I simply couldn’t claim presumablly because of network load, came back to it just now to try again and it’s suddenly saying ‘Wrong Viewing Key’ just like you guys. I also cannot work out how to delete and try again. All I can do is click ‘Claim Genesis’ leading to a ‘failed to claim SeFi notification’.

at the same time, I also have not been able to fetch my sETH balance this whole time either. Just keeps spinning. I noticed this first. Then had the problem when I made the new viewing key


I just refreshed and for a moment, it said 0 instead of Wrong Viewing Key on the secret side. Which is what the metamask side has had the whole time. But then it switched back to the red Wrong Viewing Key again.

My viewing key just fixed its self and showed my balance, i then tried to stake my SEFI, then it went back to fix viewing Key.

From what ive gathered, we just have to give it time due to congestion of sorts!!

No mention of the issues on the Secret Bridge end of things here but at least it confirms that the network is experiencing some very odd/unexpected congestion related issues. I’m guessing it’ll be the cause of the Bridge issues too.

Go to token list on your Keplr (select top left menu) and delete the viewing key. Keep in mind there’s quite a bit of congestion going on, sometimes refreshing just solves the issue.

1 Like

So the tokens came into my wallet after like ten tx. However they still show up in drop menu and when I try to stake it shows my balance as zero. Looks like the system is overwhelmed

FIX: Go to extension and allow it to change site data on all sites

Similar issue with viewing key for me. How do I delete the current incorrect key and install the correct one please-not sure if it was my late night error. I have 3 previous viewing keys thru keplr for other tokens. Thanks