Problem setting up testnet

About a month ago I was able to run the testnet with no problems. But now when I run ‘./launch.bash -t -s’, only one xterm gets opened – enigma_surface. The terminal repeatedly prints ‘enigma_surface_1: Waiting for enigma_core_1…’ for about an hour. Eventually, I get the following error:

enigma_core_1 is ready!
Running Surface in Simulation Mode
[2018-12-05 00:14:17.426227] DEBUG: main: config not found in the .enigma directory: [Errno 2] No such file or directory: ‘/root/.enigma/config.json’
[2018-12-05 00:14:17.427265] INFO: main: Starting up node.
[2018-12-05 00:14:17.428170] INFO: Node: Connecting via zmq to: tcp://:5552
Traceback (most recent call last):
File “/usr/local/lib/python3.6/”, line 193, in _run_module_as_main
main”, mod_spec)
File “/usr/local/lib/python3.6/”, line 85, in _run_code
exec(code, run_globals)
File “/root/surface/src/surface/”, line 189, in
File “/usr/local/lib/python3.6/site-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python3.6/site-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python3.6/site-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python3.6/site-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/root/surface/src/surface/”, line 84, in start
File “/root/surface/src/surface/communication/core/”, line 28, in connect
File “zmq/backend/cython/socket.pyx”, line 580, in zmq.backend.cython.socket.Socket.connect
File “zmq/backend/cython/checkrc.pxd”, line 25, in zmq.backend.cython.checkrc._check_rc
zmq.error.ZMQError: Invalid argument

If I direct the browser to http://localhost:8081 or 8082, it displays ethereum addresses. But I get errors on port 8080 and 3000 (after I try to start a dapp).

I’m running docker version 18.09.0, build 4d60db4 and docker-compose version 1.23.0-rc3, build ea3d406e.

I have tried deleting and re-cloning the git repos, but no luck.

Does anyone have any suggestion on how to fix this error? Any help would be greatly appreciated!

Hi @pmp, thanks for reporting this issue, and sorry to hear that you are experiencing this.

It’s most strange because no major changes have been pushed to the code repositories, and because I cannot replicate your error either: it continues to run fine for me on both a MacOS in simulation mode, and on an Ubuntu server with SGX.

But you are not the only one experiencing this error, because we are actively discussing this same issue in this other forum post: Problem with the millionaire problem

I would suggest two things:

  • First make sure you are running the last version of our software: run git pull on your local docker-enigma-network folder to get the latest version, and then run docker-compose build --no-cache (to rebuild all images pulling the latest versions from the dependency repos), and then try to launch again the network to see if that made any difference: ./launch.bash -t -s
  • If nothing changes, hop on that other thread that I referred to above, and help us troubleshoot the issue by answering the questions that I will post there in the next few minutes… (it’s easier to have one single conversation about the same problem :slight_smile: )


1 Like

Thank you for the response @victor! I already tried both those suggestions with no improvement. I’ll keep watching the other post and try to help as best I can.

1 Like