Signaling Proposal: Reduce Validator Fees

I have no issues with this. We can support lower fees.

As far as relayer costs come about i believe there were talks in cosmos about taking relayer fees from the end-user as part of the tx (including the relayer incentive fees). Maybe this should be pushed on the cosmos-sdk end of things.


Hey Dylan, would that directly translate into transactions and computations becoming 20x cheaper because the fees have been reduced 20x?

Yes, Keplr might need to change the defaults for most people to benefit from it though, but that’s a small change.


WhisperNode will support. Standing by for confirmation.


Yes, this is absolutely an end goal. However, it’s considered lower priority (and in my opinion they’re right) than creating a stable, effective product. In the mean time that means relayers have to eat the cost.

It’s very chain dependent on how this is handled. Some teams delegate to cover the cost, some are just given funding by the team (Osmo did this at the start).

Right now funding relayers is a complicated issue, as there’s trying to be a DAO created to cover relayer costs. This DAO is going to be made up of 7 people/entities that are intending to go for on-chain funding to cover the costs… but the DAO is in mid stages, definitely not ready for prime time.

However, this means relayers are “banded together” to not seek community funding as that’d undermine the DAO (as the DAO will be doing the exact same thing).


Yes, correct. The support team already deals with complaints about fees all day long as it is (especially with low fees rarely being accepted) - this is what I’m referencing when I say “goodwill from users”


Secret keeper 100% support this.


I’m all for it. 0.0125uscrt is what I’ve been set at for a long time anyway


As an update:

It appears the PR @assafmo put out on Osmosis has reduced our fees paid by relayers: Cheaper IBC deposit fees by assafmo · Pull Request #103 · osmosis-labs/osmosis-frontend · GitHub

Per the governance call, I’ll redo all the numbers and calculations on the 30th.


I support lowering the gas fees, I currently have mine set to 0.001uscrt based on some discussions i had with you about lowering the default gas fees a while back

1 Like

Completely agreed, also set my fees to 0.001 uscrt at the start of supernova.

1 Like

Update on pricing:

This is incomplete data, but the relayers have done several things to improve pricing:

  1. adjusted our node fees to 0, and validator fees to 0.0125
  2. change the default gas on the relayer
  3. adjusted IBC front end on Osmosis

which has led to drastically reduced fees.

Over the last week [0]:

  • 394.744851 SCRT was spent in relaying
  • 9696 transactions happened
  • Making the average tx cost 0.0407121339727723

The average cost per tx on day 1 was 0.192 SCRT per IBC transaction. Over the last 24 hours, with the updates made above, each tx is averaging 0.0043 SCRT.

One downside to this is it has led to several packets becoming stuck and requiring manual intervention (I believe 3 over the last week). This is obviously NOT ideal behavior, and would be remedied by reducing fees by more validators.

However, I consider reducing the fees as we have a resounding success.

[0]: this is incomplete data gathered by the relayers who responded to the request for their secret addresses to do the calculations

1 Like

agree and give full support

1 Like

I think its good to push this on chain


Reduced from 0.1uscrt to 0.0125uscrt


Reduced from 0.25uscrt to 0.0125uscrt. In or case, as I am sure it was with others, we just used the default settings provided/instructed.


Further update: there’s a discussion occurring in Juno to reduce all validator fees in the new mainnet to 0.01 or 0.001 as 0.025 has proven plenty stable.

@dylanschultzie are you planning on pushing this on chain?

1 Like

It is now live, I apologize for the delay!

1 Like

To update fees
To the following:

  1. Replace the gas price with the new pricing
sed -i.bak -e "s/^minimum-gas-prices *=.*/minimum-gas-prices = \"0.0125uscrt\"/" ~/.secretd/config/app.toml
  1. Restart your node
systemctl restart secret-node

That’s it!