# Install Enigma/Catalyst

**URL:** <https://forum.scrt.network/t/install-enigma-catalyst/775>\
**Category:** Developer Help\
**Created:** [April 12, 2019, 2:42am UTC](https://forum.scrt.network/t/install-enigma-catalyst/775 "2019-04-12T02:42:29Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![HawksCoin](https://avatars.discourse-cdn.com/v4/letter/h/a183cd/32.png) [@HawksCoin](https://forum.scrt.network/u/HawksCoin)\
**Post date:** [April 12, 2019, 2:42am UTC](https://forum.scrt.network/t/install-enigma-catalyst/775/1 "2019-04-12T02:42:29Z")

</div>

I am not to Catalyst. Trying to install using instructions at [https://enigma.co/catalyst/install.html](https://enigma.co/catalyst/install.html).  
Platform: Ubuntu 18.04.2 LTS  
I have tried both Acaconda & MiniConda installs which don’t complete.  
The troubleshooting steps are ok until command “pip install enigma-catalyst matplotlib”  
Looks like main error is “Could not find local HDF5 installation”.  
I have not found anything on Google to fix HDF5 issue.

1. Am I using the appropriate plateform? I saw other posts referencing “Docker” which I thought was for Windows installations.
2. When adding packages I get upgraded to python 3.7.2. Should I try to keep envirionment at python 3.6? Not sure how that would be possible when installing required files.

 ![catalyst-error](https://canada1.discourse-cdn.com/flex035/uploads/enigma1/original/1X/25eb588d9299981fbd9ce06e20e92f01ace8b1a1.jpeg)

---

<div class="post-metadata">

**Author:** ![HawksCoin](https://avatars.discourse-cdn.com/v4/letter/h/a183cd/32.png) [@HawksCoin](https://forum.scrt.network/u/HawksCoin)\
**Post date:** [April 17, 2019, 4:16am UTC](https://forum.scrt.network/t/install-enigma-catalyst/775/2 "2019-04-17T04:16:46Z")

</div>

— Success —  
… Obsticles…  
enigma-catalyst 0.5.21 has requirement certifi==2018.1.18, but you’ll have certifi 2019.3.9 which is incompatible.

I was successful with Catalyst install using the following in he troubleshooting section.  
The key was confirming was before running “pip install enigma-catalyst matplotlib”, remove wrong version of certifi, install correct version of certifi, then run “pip install enigma-catalyst matplotlib” and confirm installation.

conda env remove --name catalyst  
conda create --name catalyst python=3.6 scipy zlib  
source activate catalyst

# Now verify certifi version again

(catalyst) steve@steve-cat5:~$ conda list | grep certifi  
ca-certificates 2019.1.23 0  
certifi 2019.3.9 py36\_0

# Remove wrong cerify version

conda remove -n catalyst certifi

# Verifi cerifi removed

(catalyst) steve@steve-cat5:~ conda list | grep cert ca-certificates 2019.1.23 0 (catalyst) steve@steve-cat5:~

# Install correct version of certifi and couple of other packages

conda install certifi==2018.1.18 numpy==1.14.0 setuptools==38.5.1

# Verify correct version of certifi

(catalyst) steve@steve-cat5:~$ conda list | grep cert  
ca-certificates 2019.1.23 0  
certifi 2018.1.18 py36\_0

# Install Catalyst

pip install enigma-catalyst matplotlib

# Verify installation successful

(catalyst) steve@steve-cat5:~$ catalyst --version  
catalyst, version 0.5.21

# Congratulations! You now have Catalyst properly installed.
