# Enigma node startup on NUC 7i5 BNB giving error. Need Help!

**URL:** <https://forum.scrt.network/t/enigma-node-startup-on-nuc-7i5-bnb-giving-error-need-help/1182>\
**Category:** Secret Nodes\
**Created:** [December 8, 2019, 1:25pm UTC](https://forum.scrt.network/t/enigma-node-startup-on-nuc-7i5-bnb-giving-error-need-help/1182 "2019-12-08T13:25:44Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![aeonwise](https://avatars.discourse-cdn.com/v4/letter/a/59ef9b/32.png) [@aeonwise](https://forum.scrt.network/u/aeonwise)\
**Post date:** [December 8, 2019, 1:25pm UTC](https://forum.scrt.network/t/enigma-node-startup-on-nuc-7i5-bnb-giving-error-need-help/1182/1 "2019-12-08T13:25:44Z")

</div>

I installed a node on a Intel NUC 7i5BNB. The install was done following the guide to the T.  
SGX enabled in BIOS and safe mode disabled.  
Installation was a success  
Encountered some problems with starting the node:  
start.sh: line 6: cd: discovery-docker-network: No such file or directory  
Making sure discovery-docker-network is up to date.  
ERROR:  
Can’t find a suitable configuration file in this directory or any  
parent. Are you in the right directory?

```
    Supported filenames: docker-compose.yml, docker-compose.yaml

```

Start 9 workers on your Secret Node. Note : 9 is the max amount of workers you can run.  
sudo: ./launch.bash: command not found

Found the discovery-docker-network directory was not created as per the above error message so created one and copied the tmp folder contents to the discovery-docker-network folder in /home/nsn/ Is this step correct ?

After that i started the node , it pulled the docker images and then got the below error message and am not able to make anything about the env-template

./start.sh  
CD into Discovery-Docker-Network  
Making sure discovery-docker-network is up to date.  
WARNING: The DOCKER\_TAG variable is not set. Defaulting to a blank string.  
WARNING: The SGX\_MODE variable is not set. Defaulting to a blank string.  
WARNING: The COMPOSE\_PROJECT\_NAME variable is not set. Defaulting to a blank string.  
Pulling contract … done  
Pulling p2p … done  
Pulling client … done  
Pulling core … done  
Pulling km … done  
Start 9 workers on your Secret Node. Note : 9 is the max amount of workers you can run.  
[sudo] password for nsn:  
Creating .env file from template  
cp: cannot stat ‘.env-template’: No such file or directory  
./launch.bash: line 11: .env: No such file or directory  
SGX\_MODE not set to either HW or SW in .env file. Exiting…

Please help!! Not a programmer, but have experience running a few nodes on ubuntu.

---

<div class="post-metadata">

**Author:** ![aeonwise](https://avatars.discourse-cdn.com/v4/letter/a/59ef9b/32.png) [@aeonwise](https://forum.scrt.network/u/aeonwise)\
**Post date:** [December 9, 2019, 6:09am UTC](https://forum.scrt.network/t/enigma-node-startup-on-nuc-7i5-bnb-giving-error-need-help/1182/3 "2019-12-09T06:09:59Z")

</div>

I followed the troubleshooting guide but nothing regarding he env-template

---

<div class="post-metadata">

**Author:** ![aeonwise](https://avatars.discourse-cdn.com/v4/letter/a/59ef9b/32.png) [@aeonwise](https://forum.scrt.network/u/aeonwise)\
**Post date:** [December 9, 2019, 6:51am UTC](https://forum.scrt.network/t/enigma-node-startup-on-nuc-7i5-bnb-giving-error-need-help/1182/5 "2019-12-09T06:51:07Z")

</div>

Secure boot is disabled, but there is no safe boot option in Bios. Fast boot is also disabled

---

<div class="post-metadata">

**Author:** ![aeonwise](https://avatars.discourse-cdn.com/v4/letter/a/59ef9b/32.png) [@aeonwise](https://forum.scrt.network/u/aeonwise)\
**Post date:** [December 10, 2019, 4:06pm UTC](https://forum.scrt.network/t/enigma-node-startup-on-nuc-7i5-bnb-giving-error-need-help/1182/7 "2019-12-10T16:06:39Z")

</div>

The install has not failed. The install has completed successfully. When i give the bash start.sh command is when i get the errors. The discover docker images downloaded and after that it starts launch.sh which give the error as i have said above.

---

<div class="post-metadata">

**Author:** ![dbriggsie](https://yyz1.discourse-cdn.com/flex035/user_avatar/forum.scrt.network/dbriggsie/32/587_2.png) [@dbriggsie](https://forum.scrt.network/u/dbriggsie)\
**Post date:** [December 11, 2019, 3:56pm UTC](https://forum.scrt.network/t/enigma-node-startup-on-nuc-7i5-bnb-giving-error-need-help/1182/9 "2019-12-11T15:56:37Z")

</div>

If you haven’t made any ground on this… Can you please try this.

sudo rm -f discovery-docker-network  
sudo apt-get install git  
sudo git clone [https://github.com/enigmampc/discovery-docker-network.git](https://github.com/enigmampc/discovery-docker-network.git)

then run  
sudo bash start.sh

please let me know if it runs or if you get the same error.  
If so, then as @anon60841010 says, you will need to start fresh.

---

<div class="post-metadata">

**Author:** ![aeonwise](https://avatars.discourse-cdn.com/v4/letter/a/59ef9b/32.png) [@aeonwise](https://forum.scrt.network/u/aeonwise)\
**Post date:** [December 26, 2019, 7:35am UTC](https://forum.scrt.network/t/enigma-node-startup-on-nuc-7i5-bnb-giving-error-need-help/1182/10 "2019-12-26T07:35:22Z")

</div>

I installed the discovery testnet and now its working as i see the workers starting. Didnt go with CLI.sh as its not clear from which account i have to send the KETH. Should i send the KETH fromt he same account from which i will be staking test ENG? Which account will i receive the test ENG - It will be the same account in which i hold the mainnet ENG tokens ?
